How Disable double click -> Maximize event on the view

Feb 9, 2014 at 2:55 PM
Hi,
On login screen or other pop-up views which are opened with below similar code
        public ActionResult ChangeContractLimit(Consumer consumer, Contract contract)
        {
            ChangeContractLimitViewModel model = new ChangeContractLimitViewModel(consumer, contract);
            var vr = ViewModal(model, ViewLevel.Popup);
            
            return vr;
        }
on Workplace (Office 2013) theme when the user double click any place on the viewe or select an item or double click a control (TextBox, ComboBox) form trying to maximize itself and goes top-left corner from center of screen, how can I prevent this to happen, or disable it?

Attached pictures:
1 - NormalViewImage
d - DoubleClickedViewImage

thank you very much in advance
Coordinator
Feb 10, 2014 at 9:11 PM
In the Workplace-Shell.xaml style is the style for top level view windows. (This is part of the overall source code, but it is most easily found by downloading that XAML files only, which is provided for easy access). You can simply copy that style into your own project and then change everything there you want (including whether or not maximizing is supported and so on). Like with all other styles, if you re-define a style of the same name in your local project, it overrides what is there as the default.


Markus
Feb 16, 2014 at 1:37 PM
Thank you Markus,
working perfect.