AutoComplete in ListBox Problem

Dec 5, 2014 at 11:22 PM
Hi!

I have a problem, I am using the next datatemplate with AutoComplete for a column listbox but the element shows partially.
<DataTemplate>
                                <TextBox controls:Ex.SelectOnEntry="True"
                                    Text="{Binding FilterCuenta, UpdateSourceTrigger=PropertyChanged}"
                                    controls:AutoComplete.AutoCompleteItemsSource="{Binding CuentasContables}" 
                                    controls:AutoComplete.AutoCompleteSelectedItem="{Binding SelectedCuentaContable, Mode=TwoWay}"
                                    VerticalAlignment="Bottom" controls:AutoComplete.AutoCompleteStyle="{DynamicResource WildCat-Control-AutoComplete-FilterList}" Margin="5,2,5,3">
                                    <controls:AutoComplete.AutoCompleteItemTemplate>
                                        <DataTemplate>
                                            <Grid controls:GridEx.ColumnWidths="Auto,Auto">
                                                <TextBlock Text="{Binding Text1}" FontSize="11" Margin="2" HorizontalAlignment="Left" Panel.ZIndex="1000"/>
                                                <TextBlock Text="{Binding Text2}" FontSize="11" Margin="2,2,2,8" Grid.Column="1" Foreground="Gray" HorizontalAlignment="Center" />
                                            </Grid>
                                        </DataTemplate>
                                    </controls:AutoComplete.AutoCompleteItemTemplate>
                                    <controls:Ex.EventCommand>
                                        <controls:EventCommand Command="{Binding RefreshCuentaCommand}" Event="LostFocus" />
                                    </controls:Ex.EventCommand>
                                </TextBox>
                            </DataTemplate>
Image

Thanks
Coordinator
Dec 15, 2014 at 4:16 AM
Hmmm... I am not sure I know what you mean exactly when you say "the item shows partially"...?

Markus
Dec 30, 2014 at 1:38 PM
hi

I have the same problem
it is actually the same development

Image

The list is behind the element that contains a ListBox

there any way to fix this without changing the Framework u like it could adapt the Framework for this?

Regards
Coordinator
Dec 30, 2014 at 7:52 PM
Oh, OK, I see what you mean. The drop down is being clipped into the container, which is the view-host in that particular template. I will have to play around with that to see what I can do about it.


Markus
Jan 2, 2015 at 1:25 PM
this is.
I could not solve the problem
I would appreciate very much to help

regards

Galileo
Coordinator
Jan 2, 2015 at 1:55 PM
Yes, this is on my list, but admittedly not at the very top, since I am working on several highly pressing items.

Markus
Jan 5, 2015 at 1:27 PM
i understand

try to find a solution, however i will be on the lookout for update

regards (Y)