This project is read-only.

Is this an autocomplete bug or am I just doing something wrong?

May 1, 2013 at 11:54 PM

I have a number of places where a key to a value in a lookup table is stored with a record.
For example, the partID may be part of a detail record, but the user only sees the part description, etc.

I am currently working through the quick tip on auto complete - which seems like a good way to address lookup table values, etc.

When I try to enter this line in the edit.xaml:
it complains and insists that AutoCompleteDisplayMemeberPath is not available (intelisense also doesn't show it as an available method/property.)

I looked in the current source code (CODE.Framework.Wpf.Controls - AutoComplete) and found the code that apparently registers the AutoCompleteDisplayMemberPath Dependency Property. And all the other dependency properties do show up in intellisense.

Any idea why it might not be available or what I am doing wrong?

If I delete that specific setting, then everything compiles, but the auto complete window doesn't show up - so I am guessing I need to specify that value to make it work.

The actual error messages are:
1) The member "AutoCompleteDisplayMemeberPath" is not recognized or is not accessible.
2) The attachable property 'AutoCompleteDisplayMemeberPath' was not found in type 'AutoComplete'.

May 2, 2013 at 9:38 PM
Looks like you are going with a typo in the property name. ("memEber" instead of "member").

IntelliSense with attached properties is a bit of a problem. I find that VS sometimes has trouble discovering them.

May 3, 2013 at 2:11 AM

Since I simply copy/pasted from the quick tips ( page, you may want to update that to correct the spelling error - especially since intellisense can't seem to fine the version that is spelled correctly (but does find the others.... odd.)


May 3, 2013 at 6:28 AM
Good catch! I didn't realize that where it came from. I fixed it.

Dec 14, 2015 at 5:56 PM
Iam having this same issue still... It still shows codeControls:AutoComplete.AutoCompleteDisplayMemberPath="Name" DP as being not recognized.. even when I selected it using Intellisense, it still not recognized or not accessible... It compiles but does NOT show the dropdown of matches...

Although the demo code works that is in the CODE solution.. even though VS says that the same property is not recognized...